Snakes
First timer here and thanks in advance. I have a 8kw 2013 Generac. The red light came on and says it is switched to off.  Auto or manual will not work. When I pull up menu,.. It starts with 'English' as a prompt. Work my way thru and found the alarm log. Nothing there but history from years ago.  Battery indicator says OK,  though I am due for a replacement due to time.
Quote
Skip Douglas SkipD
It would be a good idea to post the model and serial number for your generator so that folks trying to help can know more about your unit.
Skip Douglas
Quote
Peddler
You are due for a battery, at some point the Dc voltage has been pulled below 8 volts, thus the language promt.
Quote
Snakes
Peddler wrote:
You are due for a battery, at some point the Dc voltage has been pulled below 8 volts, thus the language promt.


Thanks Peddler!  Worked like a charm. Replaced battery and clamp (broke while removing) and my Generac 8KW model 62370 is working great again. I kept thinking I would have had some low voltage or failed batt indication though. 
Great site!
Quote
78buckshot
The charger keeps the voltage up enough that the control doesn't know any better until it tries to crank, you may have had an "overcrank" at some point as it tried.
Quote
Peddler
When you replaced the battery cable clamp what type did you use?  The universal battery cable ends with a clamp held down with two bolts won't normally keep the battery cable tight enough to prevent a bad connection.
Quote
Snakes
I replaced the whole cable, like for like.
Quote
Peddler
That's the best way.
Quote