Clintvass
Hello all,

I am the owner of a Generac 20kW NG standby generator model #0058871 and serial # 6733334. After running for 2 days this last storm in the northeast, the generator began having an overspeed error and shutting off after about 2 minutes. I tried resetting the generator, and running in auto and manual and the same problem. Every year I have replaced spark plugs, oil and oil filter, and air filter. I also did the same after the error began. I am fairly new to fixing the machine, but I had a tech come out and he was there for about 5 minutes. He said all that it needed was a new mixer valve and control board. They quoted my $1100 to fix the problem. Would anyone here recommend me testing anything else prior to replacing the control board myself for around $500? Also, which valve do you think he was referring to, so I can replace it?

Thanks in advance-
Clint
Quote
grsthegreat
Did he even check resistance of the stepper motor. . If he only was there 5 minutes im sure he could nit have. You should me able to see stepper motor freely move during startup and running, you can manually try to move it and slow down rpm. I really cant diagnose like this. I would have to visually watch stepper. A video of engine starting would help. But i bet its just the stepper motor. Easy to replace yourself
Quote
78buckshot
I also would suspect the stepper motor, the least expensive and you could probably replace it yourself.
Quote
Peddler
I doubt very much it is either the mixer or the controller the stepper would be my first guess as others have said.  
Quote
bhm_to
Same generator, about 11 years old and same problem 2 springs ago. Stepper motor, did myself. Good luck. 
Quote
daveg
I have a similar problem on my 8kw.  Where can I get the stepper motor?  I am also looking to get mixer for another 8KW unit mixer (0J9894).

 

Quote
78buckshot
Call Ziller in the morning with the serial number from each generator, they can fix you up with parts.
Quote