deanp72
I sent a post a few weeks ago about my Generac starter not working. It would click and occasionally if I would keep clicking the rocker switch it would sometimes eventually start. I checked and cleaned all connections. I pulled the plates to the control panel off and watched the relay switch click in. I also made sure the battery cables were tight and clean to no avail. Then I had another generator that I service start doing the same thing. Exactly the same. I went back home to mine and started checking again. I have a spare for parts and was trying to think what to replace. Then I watched the starter gear slightly vibrate but not moving. I sprayed WD40 on the starter shaft and WOW! it all started working. I clicked many times and it started each time. I immediately went out to the other generator and sprayed and WOW! All working again. The other generator had the starter replaced last year but mine is 16 years old. I will find a better, more permanent lubricate to use. I think the starters are designed to have powerful turning power once kicked in but weak in engaging. Easy fix and might save someone from replacing the starter when all it needs is lubricated. I have 6 more that I service and will spray down all of them on their regular scheduled maintenance plan.
Quote
Steve H
Actually I'm thinking the brushes are sticking.  Next time this happens, tap the starter with a heavy screw driver handle or a small soft faced hammer.  They do build up condensation inside over time.  Not sure what the WD is doing for you.

Just an old car guy who's been there.  I went for a month like that on an old Hudson.  Didn't have the money, but i got home.  To us old car guys, this trick is still used today.
Quote
murphy
The WD of WD40 stands for Water Displacement.
Quote
Dick from Canada
As posted the brushes may be sticking but another problem may be that the  Bendix gear on the starter is not engaging  . Does the starter turn but not engage?  The gear may be stuck on the shaft. I was thought that no lubricant should be used on the starter shaft as it will attract dirt and cause the Bendix to stick. Centrifugal force pulls the gear to engage with the flywheel  and when the engine reaches the required rpm it will disengage. The Bendix gear on the starter shaft  is a loose fit and will move freely if no dirt or rust is present. Try cleaning the shaft with a fine emery and the Bendix  may have to be cleaned with a degreasing agent and air dried.  Good luck .
Quote
deanp72
I thought that at first as I am an old car guy as well but it was actually the gear shaft. Mine had been working off and on for a month now and another one that I service started doing it last week. After I found the issue an old mechanic told me that the power is in the turning and not the plunging into place with these units and yes a tiny bit of dirt or rust could hold them up. The proof is in the pudding as it was only the gear shaft and the gear that I lubricated with WD40 and I will lubricate with a more permanent method now. Thank you, Dean Patterson
Quote
10kray
Hey, you guys are amazing ! Thanks for this information it is very helpful to me. Just wanted to let you all know, keep on keeping on ! Have a great Thanksgiving guys. Ray
Quote