ElGato
Honeywell gen 35KW serial 9030080 model 03524ANAX. runs at 1800 rpm 2.4 mitsu turbo engine. Been getting low coolant error since new. Replaced sensor in 2019 with 10 hrs. tech did a conductivity test up to board and was ok. Keep getting error and is full of coolant. If i clear it 3 months go ok then gets moody and trips all the time. Gen has only 43hrs. Tech says should change power control board. Any feedback on this? Still in warranty. 
Quote
78buckshot
Has the cooling system had any problems, has it been drained and flushed, just thinking outloud about the antifreeze/water mix - maybe too much antifreeze and it can't conduct?
Quote
cookelec
I think this unit has a Nexus controller. If it is, then the sensor should be P/N 0E2507.
The most common problem is the coolant has not been changed and there will be a build up of sediment on the probe. If it has and you still get the alarm when full, have the technician test the circuit with a 1000 ohm resistor when the fault is current. If the fault clears, replace the sensor. If not then check wires 573 and 573A for continuity from the probe to the controller. If they test good, the controller may be at fault. Do it while the warranty is still in force. Those controllers are expensive.
Quote
ElGato
The fault comes while in standby, not running. They did all those tests. They concluded its the PCM. but the PCM is backordered supposedly in Generac. I still find it strange its the PCM. The gen is on the roof on a high scale property I rent  and its a PITA to bother the tenants to reset it and to climb it. The property is in PR and the gen is a must nowadays. 
Quote
Geoff Z
It is a Nexus controller. GenService shows it as 0H1827

https://plrlmf48z93rk6gt-11517156.shopifypreview.com/products/generac-0h1827-coolant-level-probe?_pos=33&_sid=cfef9325a&_ss=r
Quote
cookelec
Geoff is correct. I looked at the R200 controller by mistake. Sorry for the confusion I injected. Gen Service shows the controller in stock. Good luck. Let us know the results.
Quote