Jcurtis21
My generator started throwing a Rpm Sense Loss alarm. I installed an New Battery  . Any suggestions?     
Quote
grsthegreat
Is it even starting and running at all...even for a few seconds
Quote
Geoff Z
Moved to Generac Liquid Cooled Generators
Quote
Ron Goldstein Rongold
Did this happen before or after you changed the battery ???
Quote
Jcurtis21
It doesn't even start before it throws the code yes its is doing the same thing as it was before the battery was changed.   
Quote
grsthegreat
what error code number is being shown. a little general info would be nice.. like serial and model number
Quote
Ron Goldstein Rongold
grsthegreat wrote:
a little general info would be nice.. like serial and model number
  The model & serial #'s are in the title of the thread.
Quote
JayH

Jcurtis21 wrote:
It doesn't even start before it throws the code yes its is doing the same thing as it was before the battery was changed.   


If it doesn't crank or try to start, double-check the wiring between the battery and starter, also the battery ground cable.

Also, find wire 56 that should go to the starter relay. When you attempt a manual start you should see battery voltage on this wire during cranking. Do you hear a click from the starter relay?

Quote
78buckshot
Check the fuse at the belt driven alternator - can throw that code.
Quote
grsthegreat
  The model & serial #'s are in the title of the thread.
man... how did I miss that. Now I know I had a bad day.
Quote
Isslandboy
There may be 2 ground points, one is easy to miss, battery to engine block, and engine mount to frame.
Quote