bkgarcia
It starts up in the manual mode about 10 seconds then shuts off restarts
then stalls after 3 sec.. I have disconnected the oil temp and oil pressure switch and it still dose it.. I noted also when it dies I lose power to the ng valve and to the coils.. could I have a bad control box or stator ??
Quote
Zapme
Stator is gone bye bye. Shitty design by genajunk. They have re-designed the rotor and stator and it will cost you just a mere grand to replace both IF you do the work yourself. You cannot buy the old design stator anymore. I feel your pain because I've been there
Quote
bronco
I have to tell you those parts where not built by Generac they where made overseas, so please don't blame them.
Quote
johnc
Generac subbed out the work. Who else to blame?

I had my stator rebuilt. Can't tell you what your cost would be. My buddy owns an electric motor shop.
Quote
Zapme
Bronco, Generac put THEIR name on it. I don't like the blame word because it reminds me of that knucklehead we have in Washington. I say it is Generac's fault for the shitty design and shitty craftsmanship regardless who did the sub work. I was able to negotiate with customer service and got a new rotor and stator for around $400 but, that was after I spent hours in emails, phone calls and faxes complaining about the $1000 screwing they were trying to stick me. I also had 2 batteries explode with that unit so, I removed the wires that charged the battery and went to NAPA and got a $35 trickle charger that worked like a charm. Ooops...I forgot to mention that I had the starter rebuilt twice. This 4390-3 unit had LESS that 75 hours on it. Sorry to say but it is a Genajunk. Their newer units with the electronic governor seem to be well made. My experience with them are much less that the 4390 series. Peace and Blue Skies to ya.
Quote