PDGX
Model #: 04456-0
Propane, 4-5' 3/4"
How long since the last full maintenance: 4 months
How long have you experienced this problem: today

Description of problem: The generator would not crank/start today on power failure after having no problems like this for the last 5 years. Last Sunday's test was normal after running for 12 hours the Wednesday before with no problem.
The 'System Set' light was not on. Non fault lights are lit. The generator would not crank in manual.
When switching from Manual to Off and back, you could hear a relay click - (battery charger ??)
The battery is fully charged and does have power to the starter motor as normal. Jumped battery just to make sure.
Any suggestions are appreciated.

Thanks
Paul
Quote
d11gnccer
The relay you hear should be the start relay energized by wire 56. Is the battery 5 years old? Anytime I have ever came across a problem like this it was the battery. You can still measure 12 volts because of the charger but it's just from reading the charger.

If you have 12 volts to the starter motor and it isn't cranking turn the engine over by hand to make sure it isn't locked and check your grounds. If all are good then replace the starter.
Quote
PDGX
Battery is only 2 years old - also jumped it with another battery, there is no attempt to activate starter.

I did jumper across the starter solenoid and it is good.
Quote
Scotty306134
Rotate the engine by hand. Possibly the starter drive teeth and flywheel teeth are jammed and locked. If necessary remove the starter and check it.
Quote
Canada_Guy
PDGX;8462 wrote:
I did jumper across the starter solenoid and it is good.


What do you mean by "it is good"? When you jumpered across the starter solenoid, did the engine turn over? If so, was it cranking at a good speed?
Quote
PDGX
The engine is good, the start is good. There is no power to the control board - and no 'System Set' light. Bad switch or PC board ?

PDG
Quote
d11gnccer
Did you check fuses?
Quote
PDGX
Yes - but no power to the control panel
Quote