Dick from Canada
I'm having trouble with my CorePower ,model 58070, again . Upon it's exercise there is missing and backfiring. I have checked valve lash, changed spark plug and checked the plug lead wire for cracks. Checked the linkage on the carb and rechecked for bugs in the regulator vent. Restarts later with no grief when the engine is hot , even 8 hours later . This problem only happens after sitting  a week . Could the ignition coil be faulty ?  It has been warm and humid , moisture getting in some where?  Thanking you in advance for any suggestions . 
Quote
78buckshot
The coil is suspect, if you are certain the fuel system is correct and everything else has been checked then it's a good bet that the mag is breaking down. how old is the unit?
Quote
grsthegreat
Get a inline spark tester from napa and try that after its sit for a week. Will be real obvious if it# a spark issue the 
Quote
Dick from Canada
The unit is about 5 years old. The coil was replaced 2 year ago because of an unrelated  starting problem.  { starter } . The service tech at the time indicated that coils on these units had given him trouble in the past.  I shall install the old one I have and give it try.  In the mean time I will get a spark tester from napa . Just happy it is not winter and snowing .   
Quote
grsthegreat
i dont know..it was 97 here today. a little snow looks appetizing right about now.
Quote
Dick from Canada
I'm still not happy with the way my Core Power unit starts. Installed a used ignition coil and the results are some better. A new one is on order .  While trying to find my problem I checked the choke plate for stickiness and found it to be ok . The choke  did not cycle during startup  as indicated in the manual  . I did not follow the entire procedure for checking it , thunder not far away. Does the controller take temperature into consideration on start up or does it always cycle the choke until the desired engine rpm? A unrelated question .    The manual  states oil capacity is about 1 US quart, or about 1L. Even with a filter change it only takes about 3/4 of a liter to bring it to the full mark on the dipstick. Miss print,  wrong dipstick ? 
Quote
78buckshot
The choke should cycle regardless of temperature. Oil level and how well it drains can be skewed by the unit being out of level.
Quote
Dick from Canada
Unit sits perfectly level . Will investigate further. Thanks for the reminder to drain hot and give it lots of time.
Quote