Blaze

20181229_154315.jpg
 
Hello again I am having trouble with the battery charger in my 16kw carrier. The battery went dead and would not recharge. I  installed a new battery and checked the voltage . I saw 12.7 volts. A week later the voltage had dropped to 11.8. I looked at the connection at the module and relay looking for corrosion or loose connections.  After I plugged everything back in the battery started to charge. I waited a week and checked the voltage today and the voltage is now 13.6. I feel that is too high and may end up over charging the battery. Any thoughts would be appreciated. 
   
Quote
78buckshot
At 12.7 the charger was not raising the voltage, basically not charging. 13.6 is right on the money and tells me the charger is working at the time you checked it. It sounds like you may have had a dirty or lose terminal, keep an eye on it, I would check it every other day for a while to make sure it doesn't kill the battery again. The factory charger is not designed to revive a totally discharged battery and if you continue to have issues with it then it might need to be replaced.
Quote
Blaze
Thanks for the reply buckshot. It seems to me that the battery charging system is a little over engineered. I am only here on the weekends so I will check the voltage tomorrow and sunday. I applied dielectric grease on the module connection and that is the only thing I did. So maybe it was the connection even though it looked clean. If I were to change the charger do you recommend a alternative charger kit I saw on ziller or just stick with the module and relay?
Quote
78buckshot
Generac made some changes in the charger but I think yours is the newer version given the 2008 manufacture date of the generator, that doesn't mean the charger is not at fault though. I have never had to change the battery charge relay, only the charger for either overcharging or no charging. If you feel suspicious of the relay then replace it, shouldn't be too pricey. I would stick with the OEM parts.
Quote
Blaze
Thanks buckshot, I was looking at the ziller website and parts can be difficult to identify due to my gen is a carrier with carrier model number. Is there a equivalent generac model number? I was looking at the universal charger A0000102708 on ziller parts. If you think I am better off with a new module type can you help with a part number? I don't trust anything solid state that you wiggle it and it starts working. I think I will just replace it. I do not live where the generator is so it is difficult to monitor the voltage and I do not want to gamble with the generator not starting and my basement will flood.
Quote
78buckshot
Hi Blaze, if I understand correctly you have a battery charger that is bolted to the control cabinet and has two 2-pin plugs, is that correct?, or is it a black plastic unit with wire pigtails on each end like the A0000102708?
Quote
78buckshot
Ok, so I did a little research. Now I see that your charger is the field installed black plastic type. The one Ziller has should be the correct model. The Generac model number that would correlate to your machine would be a 0055231, this is a 17kw 2008 with no transfer switch. It has the same engine, controls, filters, plugs as your Carrier/Bryant model. Hope that gives you a little peace of mind for future needs. If you need other part numbers or info let us know.
Quote
Blaze
Thanks again for the reply. My charger does not have pigtails.  It looks like this pic I found online. s-l400.jpg 
Thanks for the model number. I did not know if the replacement charger is like above or the other (black plastic) type.
Quote
Geoff Z
I cannot read the serial number off my phone. Please send an email to orders@zillerelectric.com. Provide serial number and your request for the battery charger. We will get the correct part for you. 
Quote
78buckshot
I'm not sure if I'm reading the serial number either. It wont come up on the factory web site but the charger in the picture it the one you need. call Ziller in the morning and they can ship it out.
Quote