styronie
hello folks,
new to the forum and here goes...4390-3 NG found to have overcrank light and battery dead. replaced battery...upon setting the exerciser it cranks and runs for 8-10 seconds, cuts off, cranks and runs 8-10 sec. and keeps that cycle untill overcrank alarm lamp. any ideas greatly appreciated. thanks in advance .....jesse
Quote
ohmslaw
I would check for voltage output. I think this unit shuts down on no voltage output.
Tim
Quote
styronie
chk volts tomorrow

thanks for the response, will check tomorrow and post finding.thanks jesse
Quote
johnc
4390 unit. May want to go back thru archives and read about exploding batteries. You may have gotten lucky. Good manual available for download or even better order manual from ziller. Worth every penny.
Quote
styronie
found ziller

johnc;7417 wrote:
4390 unit. May want to go back thru archives and read about exploding batteries. You may have gotten lucky. Good manual available for download or even better order manual from ziller. Worth every penny.
i found the manual and printed it out, just finished.kind of flying blind here. i am disabled and am slow to accomplish or respond.thanks so much.......jesse
Quote
johnc
thank Ziller, I just posted an extended check out procedure, when I went to post it, I wasn't allowed.
Quote
Zapme
Styronie, I had one of those jewels myself...the ole 4390-3. I bought an extra cpu/pcb board and an extra voltage regulator. All the diagnostic tests pointed in that direction. Save yourself some time and go directly checking your stator to see if it is shorted out. There are four 10 gauge wires that come out of the stator and are numbered on the insulation.
Quote
Geoff Z
styronie, have you looked more into this issue?
Quote