Blaze
Hey guys, I am having problems with my carrier 16kw NG. It wont start, it is making noise similar to a dead battery.  I checked the voltage while attempting to start and not much voltage drop while attempting to crank. I believe the battery is good and the problem is with the starter.  I am going to remove the battery and have it carbon pile tested to be sure.
Can you give me a part number for the correct starter? 
Quote
78buckshot
 First thing to do is check the electrolyte level in the cells, if it's sealed then assume it's ok. Did you pull the battery cables and clean the posts and clamps, if they have hard black oxide on the mating surfaces they won't conduct enough current to energize the starter. After you are sure they are clean then re-test with a known good battery, if the battery is charged to 12.6 - 14.2 volts then you should see no less than 10.5 volts at the battery while the starter is cranking. If it still won't crank then check the starter contactor relay, it's a small black plastic 4 terminal relay under the control panel - it acts as a pilot relay, the control energizes the relay and the relay energizes the starter solenoid.
Quote
78buckshot
Ziller has it listed on their parts site, 0E42710SRV = $283.00, don't bite the bullet yet. 
Quote
Blaze
Thanks Buckshot for the input turns out it is the battery 13 4 volts idle, I hot wired the starter direct and voltage went to 3.5. Thanks again and have a great Easter. 
Quote
78buckshot
Glad to help, happy Easter to all.
Quote