mrleemus1
My 04456 generator shut down - when i raised the lid there was oil all over and the low oil light was on. I cant tell where the oil is comeing from. I filled back up and it did the same thing about a week later. It uses (leaks) a quart about every 5-6 hours of run time. Did it blow a seal or what? It doesnt appear to be leaking from the valve cover gaskets. What is involved to fix the problem.
the generator has about 800 hours on it.
Quote
Dennis
First thing you need to do is track down where the oil is leaking from. Clean up all the oil, run it for 1 or 2 min, shut it down and look for oil. It may be something easy like the gasket on the oil filter, oil hoses, or the oil pressure switch. good luck
Quote
MacMan
Dennis;7538 wrote:
First thing you need to do is track down where the oil is leaking from. Clean up all the oil, run it for 1 or 2 min, shut it down and look for oil. It may be something easy like the gasket on the oil filter, oil hoses, or the oil pressure switch. good luck


I agree. The fact that "there was oil all over" leads to the oil being pushed out under pressure.....oil filter gasket, oil press. sender, etc.

Clean everything up w/ brake clean spray while unit is off & cool, and then start it up manually with lid open & front cover off......should be fairly easy to locate where oil is spraying from.
Quote
bdavis
What ever happened with this....where was the leak coming from?
Quote
Calaska
Oil Fountin

My oil started pumping out of the dip stick tube after about an hour of operation. First noticed instability of engine preceding the oil. Shut down to cool. The next day after cleaning it up and pooring more oil in, I ran for 8 minutes before instability began followed by oil. Outside air temp was plus 18 at the time. Has anyone seen this happen?
Quote
ohmslaw
Frozen/bad check valve on the crankcase breather?
Quote
Scotty306134
Possibly crankcase overfilled?
Quote